Задать вопрос
8 февраля, 12:44

Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры.

+1
Ответы (2)
  1. 8 февраля, 13:33
    0
    Только степень вводится с клавы:

    Var

    P:integer;

    St:real;

    Begin

    Write ('Показатель степени (целое число) = ') ; ReadLn (P) ;

    St:=1;

    For P: = 1 to P do

    St:=St*2;

    WriteLn ('2^', P,' = ', St) ;

    End.

    Пример:

    Показатель степени (целое число) = 4

    2^4 = 16

    Степень и число вводится с клавы:

    Var

    P:integer;

    St, O:real;

    Begin

    Write ('Показатель степени (целое число) = ') ; ReadLn (P) ;

    Write ('Основание степени (вещественное число) = ') ; ReadLn (O) ;

    St:=1;

    For P: = 1 to P do

    St:=St*O;

    WriteLn (O,'^', P,' = ', St) ;

    End.

    Пример:

    Показатель степени (целое число) = 3

    Основание степени (вещественное число) = 2.5

    2.5^3 = 15.625
  2. 8 февраля, 15:56
    0
    Возведение вещественного числа x в натуральную степень n (без использования стандартных функций) :

    var n, i:integer; x, xn:real;

    begin

    write ('x = ') ;

    readln (x) ;

    write ('n = ') ;

    readln (n) ;

    xn:=1;

    for i:=1 to n do xn:=xn*x;

    writeln ('xn = ', xn:6:3) ;

    end.

    Пример:

    x = 2

    n = 5

    xn = 32
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на языке паскаль, возведение числа в степень. Степень вводится с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
1. Написать программу на языке программирования Паскаль, для вычисления значения выражения y=5x+6, если х любые числа и вводится с клавиатуры. 2.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)