Задать вопрос
6 февраля, 20:22

Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапозоне от 1 до 10 затем изменяет знак элементов с чётными индексами на противоположный. выведите на экран исходный и полученный массивы

+3
Ответы (1)
  1. 6 февраля, 20:53
    0
    Var

    b: array[1 ... 8] of integer;

    i: byte;

    begin

    randomize;

    writeln ('Исходный массив.') ;

    for i : = 1 to 8 do

    begin

    b[i] : = random (9) + 1;

    write (b[i], ' ') ;

    end;

    writeln;

    writeln ('Измененый массив.') ;

    for i : = 1 to 8 do

    begin

    if i mod 2 = 0 then b[i] : = - b[i];

    write (b[i], ' ') ;

    end;

    writeln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапозоне от 1 до 10 затем изменяет знак элементов с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
A) Составьте программу, которая заполняет масcив a[10 ... 20] случайными целыми числами в диапазоне от 10 до 20, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
1) Составте программуб которая заполняет массив а[1 ... 10] случайными целыми числами в диапозоне от 1 до 10, затем преобразовывает его, увеличивая все элементы с четными значениями на 1.
Ответы (1)