Задать вопрос
15 марта, 05:12

Идет К-ая секунда суток. Определите, сколько полных часов (H) и полных минут (М) прошло к этому моменту. (Например, если К=13257=3*3600+40*60+57, то H=3 и M=40)

Надо написать программу на основе PascalABC

+1
Ответы (1)
  1. 15 марта, 07:38
    0
    Var K, M, H: longint;

    Begin

    WriteLn ('Введите номер секунды') ;

    ReadLn (K) ;

    H:=K div 3600;

    M: = (K-H*3600) div 60;

    K:=K-H*3600-M*60;

    WriteLn ('Прошло часов: ', H, '; минут: ', M, '; секунд: ', K) ;

    Sleep (5000) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Идет К-ая секунда суток. Определите, сколько полных часов (H) и полных минут (М) прошло к этому моменту. (Например, если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике