Задать вопрос
18 октября, 15:02

Идёт k-я секунда суток. Определить, сколько полных часов (H) и полных минут (M) прошло к этому моменту.

+1
Ответы (2)
  1. 18 октября, 16:30
    0
    Program Pr1;

    uses crt;

    var k:integer;

    Begin

    clrscr;

    readln (k) ;

    writeln ('minut proshlo ', k div 60) ;

    writeln ('chasov proschlo ', Trunc (k/60) div 60) ;

    end.
  2. 18 октября, 16:36
    0
    var k:integer;

    begin

    readln (k) ;

    writeln ('H=', k div 3600) ;

    while k>=3600 do k:=k-3600;

    writeln ('M=', k div 60) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Идёт k-я секунда суток. Определить, сколько полных часов (H) и полных минут (M) прошло к этому моменту. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Сначала суток прошло n секунд, определить: сколько полных часов прошло с начала суток, сколько полных минут прошло с начала текущего часа, сколько полных секунд прошло сначала текущей минуты.
Ответы (1)
Идет К-ая секунда суток. Определите, сколько полных часов (H) и полных минут (М) прошло к этому моменту. (Например, если К=13257=3*3600+40*60+57, то H=3 и M=40) Надо написать программу на основе PascalABC
Ответы (1)
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)
Идет какая-то секунда суток. Определите сколько полных часов, полных минут и секунд прошло с начала суток
Ответы (1)
Идет k-я секунда суток. Определить, сколько целых часов (H) и целых минут (M) прошло с начала суток. Вывести на экран фразу: "Это ... часов ... минут". Вместо многоточий поставить вычисленные значения Н и М. (! На Питоне!)
Ответы (1)