Задать вопрос
2 сентября, 04:39

Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд. Выведите на экран фразу: "С начала суток прошло: ... часов, ... минут и ... секунд". Вместо многоточий вывести значения переменных.

+5
Ответы (1)
  1. 2 сентября, 04:46
    0
    Var

    i, h, m, s: integer;

    begin

    Write ('Введите количество секунд от начала суток: ') ;

    Readln (i) ;

    h : = i div 3600;

    m : = i mod 3600;

    s : = m mod 60;

    m : = m div 60;

    Writeln ('С начала суток прошло ', h, ' часов, ', m, ' минут ', s, ' cекунд')

    end.

    Тестовое решение:

    Введите количество секунд от начала суток: 13257

    С начала суток прошло 3 часов, 40 минут 57 cекунд
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Program naim4; var a, b, c, d, min:real; begin; writeln ('введите 4 числа') ; readln; min:=a; if b < min then min:=b; if c < min then min:=c; if d < min then min:=d; writeln ('минимальное ', min) ; readln; end.
Ответы (2)
Идет k-я секунда суток. Определить, сколько целых часов (H) и целых минут (M) прошло с начала суток. Вывести на экран фразу: "Это ... часов ... минут". Вместо многоточий поставить вычисленные значения Н и М. (! На Питоне!)
Ответы (1)
5. Нахождение минимального числа из введенных. Program MIN; Var A, I : Integer; Min : Integer; Begin Min:=32767; For I:=1 to 10 do Begin Write ('Vvedi chislo ') ; Readln (A) ; If A < Min then Min:=A; end; Writeln ('MIN=', Min) ; Readln; end.
Ответы (1)
Идёт k-я секунда суток. Разработайте программу, которая по введённой k-й секунде суток определяет, сколько целых часов h и целых минут m прошло с начала суток
Ответы (1)
1. Написать программу, решающую уравнение ax=b. Предусмотреть все варианты для значений a и b. 2. Идет к-ая секунда суток. Определить, сколько целых часов и целых минут прошло с начала суток. На экран вывести фразу: "It is ... hours ... minutes". 3.
Ответы (1)