Задать вопрос
28 марта, 11:35

Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы

+5
Ответы (1)
  1. 28 марта, 12:03
    0
    Для Одри можно и покороче))

    Только для случая одного корня печатается 2 одинаковых. Так тоже можно

    Var a, b, c, d: real;

    Begin

    WriteLn ('Решение ax^2 + bx + c = 0') ;

    WriteLn ('Введите a b с ') ; ReadLn (a, b, c) ;

    if a=0 then WriteLn ('Это не квадратное уравнение. Решайте его сами! ')

    else

    begin

    d:=b*b-4*a*c;

    if d<0 then Writeln ('Нет действительных корней')

    else WriteLn ('корни: ', (-b+Sqrt (d)) / (2*a),' и ', (-b-Sqrt (d)) / (2*a)) ;

    end;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto)
Ответы (1)
Дано натуральное число. Верно ли, что количество его цифр есть четное число, а само число не превышает b? Написать программу на паскале используя циклы, но не используя массивы, строковый тип и boolean
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Написать программу в паскале используя циклы: Вычислить кубы всех целых чисел от 1 до 20.
Ответы (1)