Задать вопрос
29 сентября, 06:25

Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto)

+5
Ответы (1)
  1. 29 сентября, 10:01
    0
    var

    a, b, c, x1, x2, d:real;

    begin

    write ('Введите A=') ; readln (a) ;

    write ('Введите B=') ; readln (b) ;

    write ('Введите C=') ; readln (c) ;

    D:=b*b-4*a*c;

    if D<0 then begin

    writeln ('Нет корней') ;

    end;

    if D=0 then begin

    writeln ('x1=',-b / (2*a))

    end;

    if D>0 then begin

    x1: = (-b-sqrt (d)) / (2*a) ;

    x2: = (-b+sqrt (d)) / (2*a) ;

    writeln ('x1=', x1) ;

    writeln ('x2=', x2) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребят, будте добры написать программу на паскале. Условие: надо написать программу, которая решает квадратное уравнение. (используя goto) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите то, что будет выведено на экран после исполнения данного фрагмента Паскаль-программы? ... goto m7; m1 : write ('не ') ; goto m9; m4 : write ('маслом') ; goto m4; m9: write ('испортишь') ; goto m3; m10 : write ('кашу') ; goto m5;
Ответы (2)
Нужна помощь с кодом Pascal. If k11 = k12 then Begin If k12 = k13 then Begin If k12 = 'х ' then goto win1 Else goto win2; End; End; Else goto showp1; Выдает ошибку на последнем Else Program1. pas (132) : Встречено 'Else', а ожидался оператор
Ответы (2)
Чем можно заменить оператор goto в турбо паскале. Существует программа нужно, чтобы при нажатии определенной буквы выполнялась определенный цикл, как это сделать не используя оператор безусловного перехода goto.
Ответы (1)
Напишите программу на паскале которая решает уравнение ax^2+bx+c=0 используя циклы
Ответы (1)
Дана программа, решающая определенную задачу. Проделать следующую работу: Сформулировать условие задачи, которую решает данная программа. Указать, какую (ие) подзадачу (и) решает (ют) процедура (ы) в программе.
Ответы (1)