Задать вопрос
12 марта, 13:41

2. Написать программу, определившую, поместится ли квадрат в кругу, введя с клавиатуры значения радиуса круга и площади квадрата

+3
Ответы (1)
  1. 12 марта, 14:36
    0
    Var

    S1, S2, D, A, diag:real;

    Begin

    Writeln ('Ведите площадь круга') ;

    Readln (S1) ;

    Writeln ('Ведите площадь квадрата') ;

    Readln (S2) ;

    D:=2*sqrt (S1/3.14) ;

    A:=sqrt (s2) ;

    diag:=sqrt (2*A*A) ;

    if diag<=D then writeln ('YES')

    else writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Написать программу, определившую, поместится ли квадрат в кругу, введя с клавиатуры значения радиуса круга и площади квадрата ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачу на Паскале. Заданы площади круга S1 и квадрата S2. Определить поместится ли круг в квадрате. Задачу решить при а) S1=70, S2=36,74 б) S1=0,86, S2=0,64 Квадрат поместится в круге, если диаметр окружности меньше или равен стороне квадрата.
Ответы (1)
Как известно площадь круга рассчитывается по формуле s=пr 2. составьте программу нахождения и вывода на экран значения площади круга, если значение радиуса задается с клавиатуры
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Написать программу на языке Paskal Заданы диаметр круга D и сторона квадрата А. Определить, поместится ли круг в квадрате.
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)