Задать вопрос
19 февраля, 11:28

Составить программу для решения квадратного уравнения a*x*x+b*x+c=0

+4
Ответы (1)
  1. 19 февраля, 12:33
    0
    Var

    a, b, c, D: integer;

    x, x2: real;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    write ('Введите c: ') ;

    readln (c) ;

    D : = sqr (b) - 4 * a * c;

    if D > 0 then begin

    x : = (-b - sqrt (D)) / 2 * a;

    x2 : = (-b + sqrt (D)) / 2 * a;

    writeln ('x1 = ', x, newline, 'x2 = ', x2) ;

    end;

    if D < 0 then writeln ('Корней нет.') ;

    if D = 0 then begin

    x : = (-b) / 2 * a;

    writeln ('x = ', x) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для решения квадратного уравнения a*x*x+b*x+c=0 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
Free Pascal 1. Составить программу для вычисления площади прямоугольника по его длинам сторон a и b. 2. Даны два целых числа x и y. Составить программу для нахождения большего из них. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)