Задать вопрос
30 августа, 05:46

Заполнить матрицу размерностью N на M (размер задан пользователем) по принципу:

1) Все элементы первой и последней строки, первого и последнего столбца равны 0.

2) Если первое условие не выполняется и при этом номер строки или столбца четный, то элемент равен сумме квадратов индексов.

3) Иначе - элемент равен случайному числу от - 5 до 10 (включительно).

+5
Ответы (1)
  1. 30 августа, 07:33
    0
    const xn=100; const xm=100; var x: array [1 ... xn, 1 ... xm] of integer; n, m, i, j, r: integer;

    begin write ('Введите n') ; Read (n) ; write ('Введите m') ; Read (m) ; for i : = 1 to n do beginfor j : = 1 to m do beginif ((i = 1) or (i = n) or (j = m) or (j = 1)) thenwrite (0:3,' ') else beginif (((i mod 2) = 0) or ((j mod 2) = 0)) thenwrite ((i*i+j*j) : 3,' ') else beginr: = Round (Random () * 15 - 5) ; write ((r) : 3,' ') ; end; end; end; Writeln; end; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить матрицу размерностью N на M (размер задан пользователем) по принципу: 1) Все элементы первой и последней строки, первого и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль! Заполнить матрицу размерностью N на M по следующему принципу: Если номер строки больше номера столбца, то элемент равен номеру строки. Иначе - элемент равен произведению индексов. Выведите матрицу на экран.
Ответы (1)
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).
Ответы (1)