Задать вопрос
7 мая, 00:49

Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).

+5
Ответы (1)
  1. 7 мая, 01:31
    0
    Const

    m=10;

    n=6;

    var

    a:array[1 ... 10,1 ... 6] of integer;

    i, j:integer;

    begin

    Writeln ('Элементы массива') ;

    for i:=1 to m do

    begin

    for j:=1 to n do

    begin

    a[i, j]:=sqr (i) + sqr (j) ;

    Write (a[i, j]:4)

    end;

    Writeln

    end

    end.

    Тестовое решение:

    Элементы массива

    2 5 10 17 26 37

    5 8 13 20 29 40

    10 13 18 25 34 45

    17 20 25 32 41 52

    26 29 34 41 50 61

    37 40 45 52 61 72

    50 53 58 65 74 85

    65 68 73 80 89 100

    82 85 90 97 106 117

    101 104 109 116 125 136

    const

    n = 10;

    var

    a: array[1 ... n] of integer;

    i, t: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (50) ;

    Write (a[i]:3) ;

    end;

    Writeln;

    t:=a[n];

    for i:=n-1 downto 1 do a[i+1]:=a[i];

    a[1]:=t;

    Writeln ('Результирующий массив') ;

    for i : = 1 to n do Write (a[i]:3) ;

    Writeln

    end.

    Тестовое решение:

    Элементы массива

    13 43 26 31 1 21 12 0 33 25

    Результирующий массив

    25 13 43 26 31 1 21 12 0 33
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
Помогите написать программы по программированию (Pascal ABC). Обязательно решать с использованием процедур. Задача 1. Написать программу, которая циклически сдвигает массив вправо или влево на указанное число позиций. Сдвиг должен быть кольцевым.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)