Задать вопрос
15 сентября, 02:49

Помогите написать программы по программированию (Pascal ABC). Обязательно решать с использованием процедур.

Задача 1. Написать программу, которая циклически сдвигает массив вправо или влево на указанное число позиций. Сдвиг должен быть кольцевым.

Задача 2. Написать программу перевода числа x из в. Запрос числа х, основания n и вывод результата в основной программе, а перевод в процедуре.

+4
Ответы (1)
  1. 15 сентября, 06:41
    0
    1) / / Вправо

    Const

    n=10;

    type

    ty=array[1 ... n] of integer;

    var

    ar:ty;

    i, k:integer;

    procedure push (var ar:ty) ;

    var

    i, c:integer;

    begin

    c:=ar[n];

    for i:=n downto 2 do

    ar[i]:=ar[i-1];

    ar[1]:=c;

    end;

    begin

    randomize;

    writeln ('Enter K:') ;

    readln (k) ;

    writeln ('First array:') ;

    for i:=1 to n do

    begin;

    ar[i]:=random (10) ;

    write (ar[i]:4) ;

    end;

    for i:=1 to k do

    push (ar) ;

    writeln;

    writeln ('Final array:') ;

    for i:=1 to n do

    write (ar[i]:4) ;

    end.

    2) var

    a, i, b, r, n:integer;

    s, se:string;

    procedure preob (var a, b, n:integer; var se:string) ;

    begin

    repeat

    b:=a mod n;

    a:=a div n;

    str (b, se) ;

    s+=se;

    until (a<=n-1) ;

    end;

    begin

    readln (a) ;

    readln (n) ;

    preob (a, b, n, se) ;

    str (a, se) ;

    s+=se;

    for i:=1 to length (s) div 2 do

    begin;

    se:=s[i];

    s[i]:=s[length (s) - i+1];

    s[length (s) - i+1]:=se[1];

    end;

    val (s, r, a) ;

    write (r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программы по программированию (Pascal ABC). Обязательно решать с использованием процедур. Задача 1. Написать программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Роботу дано число 123. он меняет цифры в соответствии со следующими командами "влево" - переместится в числе на одну позицию влево, "вправо" - переместится в числе на одну позицию вправо, "вверх" - заменить текущую цифру на следующую по возрастанию,
Ответы (1)
Напишите программу, которая для введенной десятичной дроби выполняет сдвиг десятичной точки на указанное число разрядов (позиций) вправо (если количество разрядов задано положительное) или влево (если количество разрядов задано отрицательное).
Ответы (1)
Написать программу 1. в которой элементы двумерного массива равны сумме квадратов индексов, 2. которая циклически сдвигает заданный одномерный массив на один элемент вправо (при этом последний элемент оказывается на месте первого элемента).
Ответы (1)
Помогите! Пароль от почтового ящика в виде четырехзначного числа Вася зашифровал так: цифры, занимающие четные разряды (нумерация разрядов ведется справа налево начиная с нуля), циклически сдвигаются вправо, а нечетные - влево на количество позиций,
Ответы (1)
Пароль от почтового ящика в виде четырехзначного числа Саша зашифровал так: цифры, занимающие четные разряды (нумерация разрядов ведется справа налево начиная с нуля), циклически сдвигаются вправо, а нечетные - влево на количество позиций, равных
Ответы (1)