Задать вопрос
4 апреля, 17:23

Создайте программу в Pascal abc

Для вычисления

1. Площади треугольника, зная длину его сторон. (По формуле Герона)

2. Площадь трапеции, если известны основания и высоты.

+1
Ответы (1)
  1. 4 апреля, 18:36
    0
    1.

    var a, b, c, p, s:real;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('s=', s:5:2) ;

    end.

    Пример:

    a=3

    b=4

    c=5

    s = 6.00

    2.

    var a, b, h, s:real;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('h=') ; readln (h) ;

    s: = (a+b) * h/2;

    writeln ('s=', s:5:2) ;

    end.

    Пример:

    a=5

    b=3

    h=2

    s = 8.00
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Создайте программу в Pascal abc Для вычисления 1. Площади треугольника, зная длину его сторон. (По формуле Герона) 2. Площадь трапеции, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Известны длины сторон треугольника a, b, c. Написать программу, вычисляющую площадь этого треугольника (по формуле Герона). Выполнить программу для исходных данных a=3, b=4, c=5. Язык Паскаль.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)