Задать вопрос
30 августа, 05:01

Сколько троек чисел x, y, z от 1 до 100 удовлетворяют условию "x + y + z делится на 17"?

Будем считать тройки, получаемые перестановкой чисел, различными. Например, (1, 2, 3) и (2, 1, 3) - это разные тройки

+2
Ответы (1)
  1. 30 августа, 05:48
    0
    Var

    x, y, z:byte;

    k:integer;

    Begin

    k:=0;

    For x: = 1 to 100 do

    For y: = 1 to 100 do

    For z: = 1 to 100 do

    if (x+y+z) mod 17 = 0 then k:=k+1;

    WriteLn ('k = ', k) ;

    End.

    k = 58823
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько троек чисел x, y, z от 1 до 100 удовлетворяют условию "x + y + z делится на 17"? Будем считать тройки, получаемые перестановкой ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача E Обратная перестановка Перестановкой из N чисел называется - последовательность чисел, где каждое число от 1 до N встречается ровно один раз. Перестановка b1, b2, ..., bN является обратной перестановкой перестановки a1, a2, ...
Ответы (1)
Составьте программу и блок-схему для решения следующей задачи. Учитель за урок ставит A двоек, B троек, C четверок, D пятерок (A, B, C и D каждый день разные). Сколько двоек, троек, четверок и пятерок поставит учитель за учебную неделю.
Ответы (1)
Перестановкой длины n называется последовательность из n чисел, в которой каждое из чисел от 1 до n встречается ровно 1 раз. Например, (3, 4, 5, 1, 2) и (1, 2) - перестановки, а (1, 4, 3) и (2, 1, 3, 2) - нет.
Ответы (1)
Найдите количество троек натуральных чисел X, Y, Z на интервале [10; 5000], которые удовлетворяют условиям: Х
Ответы (1)
Дано 4-значное число. Найти: 1) число, полученное при прочтении его цифр справа налево; 2) число, образованное перестановкой двух первых и двух последних цифр заданного числа;
Ответы (1)