Задать вопрос
16 декабря, 05:33

Даны 2 четырехзначные числа, как в паскале найти сколько цифр в них совпадают

+2
Ответы (1)
  1. 16 декабря, 06:11
    0
    Var a, b:array[1 ... 4] of longint; i, j, x, y, k:longint;

    Begin

    read (x, y) ;

    for i:=1 to 4 do

    begin

    a[i]:=x mod 10;

    x:=x div 10;

    end;

    for i:=1 to 4 do

    begin

    b[i]:=y mod 10;

    y:=y div 10;

    end;

    for i:=1 to 3 do

    for j:=i+1 to 4 do

    if (a[i]=b[j]) then k:=k+1;

    writeln (k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 2 четырехзначные числа, как в паскале найти сколько цифр в них совпадают ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Написать Программу на паскале. Дано произведение цифр числа равное 40. Найти эти четырехзначные числа.
Ответы (1)
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
Ребята помогите! Решать пыталась, но прога выводит ошибки! Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна сумме сред-них цифр, а само число делится на число А.!
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)