Задать вопрос
21 декабря, 12:03

Написать Программу на паскале. Дано произведение цифр числа равное 40. Найти эти четырехзначные числа.

+1
Ответы (1)
  1. 21 декабря, 15:32
    0
    var i: integer;

    begin

    for i : = 1000 to 9999 do

    if (i div 1000) * (i div 100 mod 10) * (i div 10 mod 10) * (i mod 10) = 40

    then writeln (i)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать Программу на паскале. Дано произведение цифр числа равное 40. Найти эти четырехзначные числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите составить программу в паскале! Дано четырехзначное число. Найти а) сумму его цифр, б) произведение его цифр.
Ответы (1)