Задать вопрос
16 декабря, 01:05

Паскаль найти все простые числа меньшие заданного x

+5
Ответы (1)
  1. 16 декабря, 01:49
    +1
    Var x, i, j, k:integer;

    begin

    write ('x = ') ;

    readln (x) ;

    writeln ('Простые числа:') ;

    for i:=2 to x-1 do

    begin

    k:=0;

    for j:=2 to round (sqrt (i)) do

    if i mod j=0 then k:=k+1;

    if k=0 then write (i,' ') ;

    end;

    end.

    Пример:

    x = 30

    Простые числа:

    2 3 5 7 11 13 17 19 23 29
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль найти все простые числа меньшие заданного x ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
На языке паскаль абс написать программу (Не глушилку, а нормальную программу) (желательно с помощью Циклов и If-ов) Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)