Задать вопрос
30 мая, 04:49

Ребята помогите! Решать пыталась, но прога выводит ошибки! Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна сумме сред-них цифр, а само число делится на число А.!

+2
Ответы (1)
  1. 30 мая, 06:52
    0
    Program Task1;

    var

    a, b, c, d, i: integer;

    begin

    for i: = 1000 to 9999 do

    begin

    a : = i mod 10;

    b : = i div 10 mod 10;

    c : = i div 100 mod 10;

    d : = i div 1000 mod 10;

    if (a + d = b + c) then

    writeln (i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ребята помогите! Решать пыталась, но прога выводит ошибки! Найти все четырехзначные натуральные числа, у которых сумма крайних цифр равна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Прога, которая определяет количество чисел, оканчивающихся на 5, прога получает на вход кол во чисел, а затем сами числа, программа должна вывести одно число-количество чисел оканчивающихся на 5
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Паскаль ABC Пользователь вводит с клавиатуры два числа. Если сумма чисел больше, либо равна 100, то программа выводит "Разряд выше десятков", если сумма меньше 100, но больше либо равна 10, то программа выводит "Разряд выше единиц", если сумма чисел
Ответы (1)