Задать вопрос
13 февраля, 15:15

2. Дано натуральное n. Вычислить: 1/1^1 + 1/2^2 + ... + 1/n^n.

+5
Ответы (1)
  1. 13 февраля, 17:51
    0
    Var n, i, j:integer; st, s:real;

    begin

    readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    st:=1;

    for j:=1 to i do st:=st*i;

    s:=s+1/st;

    end;

    writeln ('s = ', s:6:4) ;

    end.

    Пример:

    3

    s = 1.2870
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2. Дано натуральное n. Вычислить: 1/1^1 + 1/2^2 + ... + 1/n^n. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2). 3. Дано целое число А.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)