Задать вопрос
8 августа, 22:56

Найдите разность максимального и минимального из четырёх чисел.

+3
Ответы (1)
  1. 8 августа, 23:04
    0
    Var

    num: array[1 ... 4] of integer;

    min, max: integer;

    begin

    read (num[1], num[2], num[3], num[4]) ;

    min : = num[1];

    max : = num[1];

    for var k : = 1 to 4 do if num[k] > = max then max : = num[k];

    for var k : = 1 to 4 do if num[k] < = min then min : = num[k];

    write (max - min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите разность максимального и минимального из четырёх чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность максимального и минимального чисел
Ответы (1)
Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального элементов. (Составить программу Pascal)
Ответы (1)
Дано трехзначное целое число. Найти произведение этого числа на разность максимального и минимального чисел, составленных их цифр исходного числа. Например для заданного числа 315 получим: 315 * (531 - 135) = 124740
Ответы (1)