Задать вопрос
13 января, 11:47

Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность максимального и минимального чисел

+4
Ответы (1)
  1. 13 января, 13:05
    0
    Программа без массива:

    const n=10;

    var a, i, max, min:integer;

    begin

    Randomize;

    min:=69; max:=15;

    for i:=1 to n do

    begin

    a:=random (55) + 15;

    write (a,' ') ;

    if a>max then max:=a;

    if a
    end;

    writeln;

    writeln ('max-min = ', max,'-', min,' = ', max-min) ;

    end.

    Пример:

    21 16 40 57 41 63 48 50 54 45

    max-min = 63-16 = 47

    Программа с массивом:

    const n=10;

    var a:array[1 ... n] of integer;

    i, max, min:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (55) + 15;

    write (a[i],' ') ;

    end;

    writeln;

    min:=a[1]; max:=a[1];

    for i:=2 to n do

    begin

    if a[i]>max then max:=a[i];

    if a[i]
    end;

    writeln ('max-min = ', max,'-', min,' = ', max-min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу которая в последовательности целых чисел выбранных случайном образом из диапазона от 15 до 69 определяет разность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)