Задать вопрос
17 августа, 17:49

Ввести с клавиатуры два числа x, y. Большее число заменить на частное, x на y. Меньшее число заменить на остаток от деления х на у

+1
Ответы (1)
  1. 17 августа, 20:03
    0
    Var x, y, max, min: integer;

    begin

    readln (x, y) ;

    max:=0; min:=0;

    if x>y then begin

    max:=x div y;

    min:=x mod y;

    writeln (max,' ', min) ;

    end;

    if x
    min:=x div y;

    max:=x mod y;

    writeln (max,' ', min) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести с клавиатуры два числа x, y. Большее число заменить на частное, x на y. Меньшее число заменить на остаток от деления х на у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
1) Ввести 2 числа, заменить число суммой чисел, а большее произведением. 2) Ввести 2 числа А и В заменить первое нулем если оно меньше второго. 3) Журнал стоит k руб. Какую сдачу получит покупатель если у него в руб.
Ответы (1)
Помогите решить задачу на паскале. Дан массив B (n*m). Элементы массива ввести с клавиатуры. Найти сумму элементов, которые больше данного числа A, но меньше данного числа С. Числа A и С ввести с клавиатуры
Ответы (1)