Задать вопрос
21 ноября, 10:32

Дан массив из 10 элементов определить где положительных элементов больше в 1 или во 2 половине. 1 половина от 1 до 5. 2 половина от 6 до 10

+3
Ответы (1)
  1. 21 ноября, 10:57
    0
    Var

    a:array[1 ... 10] of integer;

    cnt1, cnt2, i:integer;

    begin

    For i: = 1 to 10 do

    Read (a[i]) ;

    for i: = 1 to 5 do

    if a[i] > 0 then cnt1 : = cnt1 + 1;

    for i: = 6 to 10 do

    if a[i] > 0 then cnt2 : = cnt2 + 1;

    if cnt1 = cnt2 then Writeln ('Количество пол-х элементов одинаково') ;

    if cnt1 > cnt2 then Writeln ('Количество пол-х элементов больше в первой половине') ;

    if cnt1 < cnt2 then Writeln ('Количество пол-х элементов больше во второй половине') ;

    end.

    Пример:

    -1 - 2 3 5 0 4 6 7 - 2 - 5

    Количество пол-х элементов больше во второй половине
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 10 элементов определить где положительных элементов больше в 1 или во 2 половине. 1 половина от 1 до 5. 2 половина от 6 до 10 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)