Задать вопрос
25 декабря, 16:44

Дано 6 цифр. Вывести есть ли среди них повторяющиеся.

Написать программу Pascal ABC

+5
Ответы (1)
  1. 25 декабря, 20:19
    0
    Var s: set of integer;

    i, a, k: integer;

    begin

    s:=[]; k:=0;

    write ('введите 6 чисел через пробел ') ;

    for i:=1 to 6 do

    begin

    read (a) ;

    if a in s then inc (k) ;

    s:=s+[a];

    end;

    if k>0 then writeln ('есть повторяющиеся')

    else writeln ('нет повторяющихся') ;

    end.

    введите 6 чисел через пробел 10 12 15 19 17 15

    есть повторяющиеся

    введите 6 чисел через пробел 17 19 21 13 14 15

    нет повторяющихся
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 6 цифр. Вывести есть ли среди них повторяющиеся. Написать программу Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)