Задать вопрос
30 июня, 01:05

Паскаль. Составить программу, которая по введенному числу в диапазоне 0-15, выдает его соответствующий шестнадцатеричный эквивалент.

+1
Ответы (1)
  1. 30 июня, 03:40
    0
    uses

    SysUtils;

    var

    s:string;

    i, sum, multipler, temp:integer;

    begin

    multipler : = 1;

    Writeln ('Vvedite shestnadtsateri4noe 4islo') ;

    Readln (s) ;

    s : = Trim (s) ;

    for i: = Length (s) downto 1 do begin

    case s[i] of

    '1' ... '9' : temp : = StrToInt (s[i]) ;

    'A' ... 'F' : temp : = 10 + ord (s[i]) - ord ('A') ;

    'a' ... 'f' : temp : = 10 + ord (s[i]) - ord ('a') ;

    else

    Writeln ('Nedupustimii sumvol: ', s[i]) ;

    Readln;

    exit;

    end;

    sum : = sum + multipler * temp;

    multipler : = multipler * 16;

    end;

    Writeln (sum) ;

    Readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. Составить программу, которая по введенному числу в диапазоне 0-15, выдает его соответствующий шестнадцатеричный эквивалент. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [-10,10], выводит его на экран, а затем находит индекс последнего элемента, равного введённому числу X.
Ответы (1)
Уровень C. Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне [10,50], выводит его на экран, а затем находит индексы всех элементов, равных введённому числу X.
Ответы (1)
Написать программу, которая бы по введенному числу от 1 до 5 (номеру курса) выдает соответствующее сообщение "Привет, первокурсник".
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)