Задать вопрос
8 ноября, 23:01

Винни-Пуху прислали посылку - K литров мёда. Сначала он попытался разлить его в бочонки по 2 литра, но вот незадача - 1 литр остался. Потом попытался разлить в бочонки по 3 литра, и опять осталось 2 литра. И так далее, пока он не разлил мёд в бочонки по N литров, и у него осталось N-1 литров мёда. Определите, какое минимальное количество мёда могли прислать Винни.

Формат входных данных:

Строка, содержащая целое число N (2≤N≤19).

Формат выходных данных:

Вывести требуемое число K.

+1
Ответы (1)
  1. 9 ноября, 02:52
    0
    Var n, k, i:integer; f:boolean;

    begin

    readln (n) ;

    k:=1;

    f:=false;

    while not f do

    begin

    k:=k+1;

    f:=true;

    for i:=2 to n do

    f:=f and (k mod i=i-1) ;

    end;

    writeln (k) ;

    end.

    Пример (для 19 долго считает, можно оптимизировать, если нужно) :

    19

    232792559
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Винни-Пуху прислали посылку - K литров мёда. Сначала он попытался разлить его в бочонки по 2 литра, но вот незадача - 1 литр остался. Потом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Задача C. Делители Дано целое число N. Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < = N < = 10^12) Формат выходных данных Выведите ответ к задаче
Ответы (1)
Паскаль Формат входных данных Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Формат выходных данных Необходимо вывести значение наибольшего элемента в массиве.
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Дано натуральное трёхзначное число n. Найдите сумму и произведение цифр в нём. Формат входных данных Вводится целое число n (100≤n≤999) Формат выходных данных Требуется вывести сумму и произведение его цифр через пробел.
Ответы (1)