Задать вопрос
9 июля, 19:49

Дан массив x1, ... x100.

Найти сумму эелементво массива от x1 до Xmin

+3
Ответы (1)
  1. 9 июля, 20:46
    0
    Var

    n, i, k, s, min:longint;

    a:array[1 ... 100] of longint;

    begin

    Write ('Write size array: ') ; readln (n) ;

    for i:=1 to n do

    begin

    a[i]:=Random (50) ;

    write (a[i]:4) ;

    end;

    min:=a[1];

    k:=1;

    s:=0;

    for i:=1 to n do

    if a[i]
    then

    begin

    min:=a[i];

    k:=i;

    end;

    for i:=1 to k do

    s:=s+a[i];

    writeln (s) ;

    readln

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив x1, ... x100. Найти сумму эелементво массива от x1 до Xmin ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
можете объяснить за что отвечает xsearch? program c4; var n: integer; x, y: integer; xmin, xmax: integer; xsearch: boolean; ymin, ymax: integer; i: integer; s: real; begin xsearch : = true; xmin : = 0; xmax : = 0; ymin:=0; ymax : = 0; readln (n) ;
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)