Задать вопрос
11 марта, 12:39

Написать программу решения квадратных уравнений. Вычисление D оформить процедурой (паскаль).

+5
Ответы (1)
  1. 11 марта, 15:41
    0
    Var a, b, c, d:real;

    procedure p (a, b, c:real; var d:real) ;

    begin

    d:=b*b-4*a*c;

    end;

    begin

    readln (a, b, c) ;

    p (a, b, c, d) ;

    if d<0 then writeln ('Корней нет')

    else if d=0 then writeln ('x = ',-b / (2*a) : 3:1)

    else writeln ('x1 = ', (-b+d) / (2*a) : 3:1,' x2 = ', (-b-d) / (2*a) : 3:1) ;

    end.

    Пример:

    2 3 1

    x1 = - 0.5 x2 = - 1.0
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу решения квадратных уравнений. Вычисление D оформить процедурой (паскаль). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Решить задачи: а) Дано квадратное уравнение. Найти решения уравнения, оформив вычисление корней в процедуре с параметрами и без параметров. б) Найти наименьшее из четырех чисел, оформив вычисление минимума из двух чисел процедурой.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Написать программу для решения уравнения AX2 + BX+C=0. (Дописать до конца) 2) Написать программу для решения неравенства Bx+C
Ответы (1)
Задание: составить программу решения задачи. Указания к выполнению: самостоятельно выполнить все этапы решения задачи. Ввод и вывод матрицы оформить в виде процедур.
Ответы (1)