Задать вопрос
4 апреля, 04:35

Задание: составить программу решения задачи.

Указания к выполнению: самостоятельно выполнить все этапы решения

задачи. Ввод и вывод матрицы оформить в виде процедур. При

необходимости выделить в задаче вспомогательные алгоритмы и оформить

их в виде подпрограмм. паскаль

Дана матрица, определить количество "особых" элементов. Элемент

считается "особым", если он больше суммы остальных элементов строки.

.

+3
Ответы (1)
  1. 4 апреля, 08:12
    0
    Const

    n = 10;

    m = 10;

    type

    Matrix = array[1 ... n, 1 ... m] of integer;

    procedure EnterMas (var Mas: Matrix) ;

    var i, j: integer;

    begin

    randomize;

    for i : = 1 to n do

    for j : = 1 to m do

    Mas[i, j] : = random (100) ;

    end;

    procedure GiveMas (var Mas: Matrix) ;

    var i, j: integer;

    begin

    for i : = 1 to n do

    begin

    for j : = 1 to m do

    begin

    write (Mas[i, j], ' ') ;

    end;

    writeln;

    end;

    end;

    function SumStroki (Mas: Matrix; i, k: integer) : integer;

    var

    j, sum: integer;

    begin

    sum : = 0;

    for j : = 1 to m do

    Sum : = Sum + Mas[i, j];

    SumStroki : = sum - k;

    end;

    function Element (var Mas: Matrix) : integer;

    var

    i, j, count: integer;

    begin

    count : = 0;

    for i : = 1 to n do

    for j : = 1 to m do

    if Mas[i, j] > SumStroki (Mas, i, Mas[i, j]) then inc (count) ;

    Element : = count;

    end;

    var Mas: Matrix;

    Sum, Max: integer;

    begin

    EnterMas (Mas) ;

    GiveMas (Mas) ;

    writeln ('Кол-во особых элементов ', Element (Mas)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание: составить программу решения задачи. Указания к выполнению: самостоятельно выполнить все этапы решения задачи. Ввод и вывод матрицы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите истинные высказвания. а) Человек разрабатывает алгоритмы б) Компьютер разрабатывает алгоритмы в) Исполнитель разрабатывает алгоритмы г) Человек управляет работой других исполнителей по выполнению алгоритмов д) Компьютер управляет работой
Ответы (2)
Что из этого являются истинными высказываниями? 1. человек исполняет алгоритмы 2. компьютер сам выполняет алгоритмы (программы) 3. исполнитель четко и безошибочно выполняет алгоритмы, составленные из команд, входящих в его СКИ. 4.
Ответы (1)
Укажите истинные высказывания: 1. а) Человек разрабатывает алгоритмы б) Человек управляет работой других исполнителей по выполнению алгоритмов в) Человек исполняет алгоритмы 2.
Ответы (1)
Задана матрица размером NxM. Определить k - количество "особых" элементов матрицы, считая элемент "особым", если он больше суммы остальных элементов своего столбца.
Ответы (1)
Укажите истинные высказывания (отметьте галочкой) 1) Человек разрабатывает алгоритм Человек управляет работой других исполнителей по выполнению алгоритмов Человек исполняем алгоритмы 2) Компьютер разрабатывает алгоритмы Компьютер управляет работой
Ответы (1)