Задать вопрос
11 марта, 10:53

В двумерном массиве 4 х3 найти количество элементов, больших - 5. Если таких элементов не оказалось - вывести сообщене "Таких элементов нет!". Элементы ввести с клавиатуры.

+1
Ответы (1)
  1. 11 марта, 14:52
    0
    Var a: array [1 ... 4, 1 ... 3] of integer;

    i, j, k: integer;

    begin k:=0;

    for i:=1 to 4 do

    for j:=1 to 3 do

    begin begin read (a[i, j]) ;

    if (a[i, j]>-5) then inc (k) ;

    end;

    writeln; {чтобы перейти на новую строку}

    end;

    if (k0) then writeln ('k=', k)

    else writeln ('таких элементов нет') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве 4 х3 найти количество элементов, больших - 5. Если таких элементов не оказалось - вывести сообщене "Таких элементов ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)