Задать вопрос
10 августа, 23:01

Надо написать программу: ввести 10 любых чисел и посчитать сколько из этих чисел положительных

+2
Ответы (1)
  1. 11 августа, 02:56
    0
    Program suma;

    const n = 10;

    Var a:array [1 ... n] of integer;

    i, sum:integer;

    begin

    sum:=0;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do if a[i] < 0 then Inc (sum) ;

    write (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Надо написать программу: ввести 10 любых чисел и посчитать сколько из этих чисел положительных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести массив из 10 положительных чисел. Программа должна посчитать сумму чисел кратных 5. Написать программу PascalABC.
Ответы (1)
Ввести массив из 10 положительных чисел. Программа должна посчитать количество чисел, которые делятся на 2 или на 3. Написать программу PascalABC.
Ответы (1)
1. Ввести с клавиатуры длину и ширину прямоугольной двери. Кроме того, ввести длину, ширину и высоту шкафа - прямоугольного параллелепипеда. Выяснить, можно ли пронести шкаф через дверь, не разбирая его. 2. Ввести три вещественных числа с клавиатуры.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Помогите с кодом по паскалю.→Нужно чтобы ответ который показывается было написано первый столбец столько положительных чисел а если нет положительных чисел в столбце то писало нет положительных чисел в этом столбце←Столбцы пронумеровать Изначально
Ответы (1)