Задать вопрос
27 декабря, 23:39

Найдите количество четных цифр в десятичной записи числа n.

На Алгоритмическом Языке

+2
Ответы (1)
  1. 28 декабря, 01:04
    0
    Program z2; var x, y, k:integer; Begin readln (x) ; k:=0; while x0 do begin y:=x mod 10; if y mod 2 = 0 then k:=k+1; x:=x div 10; end; writeln ('k=', k) ;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите количество четных цифр в десятичной записи числа n. На Алгоритмическом Языке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи • Найдите сумму цифр числа; • Найдите первую цифру числа; • Поменяйте порядок цифр числа на обратный; • Найдите количество четных цифр числа; • Найдите наибольшую цифру числа; • Найдите сумму цифр числа, больших 5.
Ответы (1)
1. Процессор обрабатывает информацию, представленную: 1) в десятичной системе счисления. 2) на языке программирования высокого уровня 3) на алгоритмическом языке 4) на машинном языке 2.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Перевести в восьмеричную систему счисления. 29,05 (в десятичной) 50,99 (в десятичной) 37,04 (в десятичной) 40,19 (в десятичной) 92,55 (в десятичной)
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)