Задать вопрос
16 сентября, 04:20

Даны величины A, B, C, D. Требуется переставить значения величин так:

В должно получить значение А, С значение В, D значение С, а А значение D.

+5
Ответы (2)
  1. 16 сентября, 07:06
    0
    Создавай доп. переменную, в которую копируй значение пер-й "А". Дальше переставляй В в А, С в В а D в C. Потом из доп. переменной значение А кидай в D
  2. 16 сентября, 08:13
    0
    Это вариант замены значений со сдвигом по кольцу. Делается через вспомогательную переменную.

    var

    a, b, c, d, t: integer;

    begin

    Write ('Введите четыре целых числа через пробел: ') ;

    Readln (a, b, c, d) ;

    t : = d;

    d : = c;

    c : = b;

    b : = a;

    a : = t;

    Writeln (a, ' ', b, ' ', c, ' ', d)

    end.

    Тестовое решение:

    Введите четыре целых числа через пробел: 1 2 3 4

    4 1 2 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны величины A, B, C, D. Требуется переставить значения величин так: В должно получить значение А, С значение В, D значение С, а А ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
написать программу для ввода значения величины X целого типа, присваивания величине Y действительного типа значения 2.5, вычисления значения величины Z=X/Y и вывода значения величины Z. Протестировать алгоритм для X=5, X=0, X=-8.75
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Даны величины a b c d. Составьте алгоритм для перемещения значений этих величин по такому принципу: b должно получить значение a; c - значение b; d - значение c.
Ответы (2)
Ввести одномерный массив A, вывести его. Переставить в обратном порядке все элементы между максимальным и предпоследним отрицательным элементом. Помогите, не могу найти предпоследний элемент в массиве, и как их переставить?
Ответы (1)
Даны величины переменных A, B, C, D. Требуется перенести значения переменных, следующим образом: в D сумму значений переменных С и В, в переменную А поместить значение из В, в В значение из С, в С значение из D решение в паскале
Ответы (1)