Задать вопрос
4 сентября, 15:42

Найдите все простые числа на отрезке [a, b] их сумму и произведение

(составить программу в pascal)

+4
Ответы (1)
  1. 4 сентября, 16:33
    0
    Program n1;

    function isprost (x: integer) : boolean;

    var i: integer;

    begin

    if x<2 then isprost:=false else

    begin

    isprost:=true;

    for i : = 2 to round (sqrt (x)) do if x mod i = 0 then isprost:=false;

    end;

    end;

    var a, b, i, sum: integer;

    p: real;

    begin

    writeln ('введите границы отрезка [a; b] (предполагается, что числа натуральные) ') ;

    write ('a=') ;

    readln (a) ;

    write ('b=') ;

    readln (b) ;

    p:=1;

    sum:=0;

    if (a<=0) or (b<=0) then write ('ошибка, числа не натуральные')

    else begin

    writeln ('простые числа на отрезке [', a,'; ', b,']') ;

    for i:=a to b do if isprost (i) then

    begin

    p:=p*i;

    sum:=sum+i;

    write (i,' ') ;

    end;

    writeln;

    writeln ('их сумма: ', sum) ;

    writeln ('их произведение: ', p) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите все простые числа на отрезке [a, b] их сумму и произведение (составить программу в pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)