Задать вопрос
19 января, 03:21

Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами

+4
Ответы (1)
  1. 19 января, 05:39
    0
    Желательно в задании уточнять тип массива (целый, вещественный) и споособ его генерации (ввод с клавиатуры, генератор случайных чисел).

    В данной программе массив получен с помощью генератора случайных чисел

    Program raznost;

    Uses Crt;

    const n=100; {максимальный размер массива}

    var a:array[1 ... n] of integer;

    i, m:integer;

    k, s, rez:longint;

    begin

    clrscr;

    write ('Введите К: ') ;

    readln (k) ;

    write ('Введите размер массива <100: ') ;

    readln (m) ;

    randomize;

    write ('Исходный массив:')

    s:=0;

    for i:=1 to m do

    begin

    a[i]:=random (50) + 25;

    write (i:3) ;

    if (i mod 2) 0 then s:=s+a[i];

    end;

    writeln;

    rez:=k-s;

    writeln ('Разность между K и суммой всех элементов массива с нечетными индексами=', rez) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на паскале: найти разность между К и суммой всех элементов массива с нечетными индексами ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)