Задать вопрос
13 сентября, 12:57

Составить программу которая считывает целое число. Если оно чётное и положительно увеличить его в два раз, в противном случае увеличить в 10 раз.

+2
Ответы (1)
  1. 13 сентября, 16:09
    0
    C#:

    class Program

    {

    static void Main (string[] args)

    {

    int a;

    a = Convert. ToInt32 (Console. ReadLine ()) ;

    if (a % 2 = = 0)

    {

    a * = 2;

    }

    else

    {

    a * = 10;

    }

    Console. WriteLine (a) ;

    Console. ReadLine () ;

    }

    }

    Pascal:

    program n;

    var

    a: integer;

    begin

    readln (a) ;

    if a mod 2 = 0 then

    a * = 2

    else

    a * = 10;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу которая считывает целое число. Если оно чётное и положительно увеличить его в два раз, в противном случае увеличить в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal Составить программу, которая считывает целое число. Если оно четное и положительное, увеличить его в два раза, в противном случае увеличить в 10 раз
Ответы (1)
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
Напишите программу, которая считывает целое число и выводит текст, аналогичный приведенному в примере (пробелы важны!) : Входные данные Вводится целое число (гарантируется, что число находится в диапазоне от - 1000 до + 1000).
Ответы (1)
Составить программу, считывает возраст, если он меньше 18, выводит сообщение несовершеннолетний в противном случае совершеннолетний
Ответы (1)
Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.
Ответы (1)