Задать вопрос
4 ноября, 07:56

Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.

+3
Ответы (1)
  1. 4 ноября, 09:20
    0
    Var

    a, b:integer;

    begin

    Readln (a, b) ;

    if (a+b) mod 3 = 0 then

    Writeln ((a+b) / 3)

    else

    Writeln (a+b) ;

    end.

    Пример:

    12 9

    7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Pascal Составить программу, которая считывает целое число. Если оно четное и положительное, увеличить его в два раза, в противном случае увеличить в 10 раз
Ответы (1)
Составить программу которая считывает целое число. Если оно чётное и положительно увеличить его в два раз, в противном случае увеличить в 10 раз.
Ответы (1)
Составить программу, считывает возраст, если он меньше 18, выводит сообщение несовершеннолетний в противном случае совершеннолетний
Ответы (1)
Ввести 2 числа если их сумма больше 100 то уменьшите сумму этих чисел в 2 раза и выведите результат на экран. В противном случае увеличте сумму чисел на 20 и выведите результат на экран
Ответы (1)
Напишите программу, которая считывает с клавиатуры одно за другим два дробных числа, а затем строку. Если эта строка является обозначением одной из четырёх основных математических операций (+, -, * или /), то выведите результат применения этой
Ответы (1)