Задать вопрос
27 ноября, 15:12

Дан массив из n элементов. Найти сумму отрицательных элементов с четными индексами и отдельно с нечетными. (Паскаль) 9 класс

+3
Ответы (1)
  1. 27 ноября, 17:07
    0
    Var n, i, s1, s2: integer; a: array [1 ... 32767] of integer;

    begin

    readln (n) ;

    s1:=0;

    s2:=0;

    for i:=1 to n do read (a[i]) ;

    for i:=1 to n do begin

    if (a[i]<0) and (i mod 2=0) then s1:=s1+a[i]

    end;

    for i:=1 to n do begin

    if (a[i]<0) and (i mod 20) then s2:=s2+a[i]

    end;

    writeln (s1) ;

    writeln (s2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из n элементов. Найти сумму отрицательных элементов с четными индексами и отдельно с нечетными. (Паскаль) 9 класс ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Программирование. Паскаль. Массивы 1) Дан массив Р (15). Найти сумму всех отрицательных элементов с четными индексами. Полученный результат вывести на экран. 2) Ввести с пульта оператора массив МАС1 семь целых чисел.
Ответы (1)
Составить программу, которая заполняет массив А[1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает. Вывести на экран исходный и полученный массив.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)