Задать вопрос
24 сентября, 07:45

Дан массив K[1 ... 37] в интервале от 0 до 100. Найти сумму элементов массива, которые являются 2-х значными числами и кратные 3, и заменить их на максимальных

+4
Ответы (1)
  1. 24 сентября, 08:35
    0
    Var

    i, sum, max:integer;

    K: array [1 ... 37] of integer;

    begin

    writeln ('Введите массив') ;

    for i:=1 to 37 do

    read (K[i]) ;

    sum:=0;

    max:=0;

    for i:=1 to 37 do begin

    if max
    max:=K[i];

    end;

    for i:=1 to 37 do begin

    if (K[i]>9) and (K[i] mod 3=0) then begin

    sum:=sum+K[i];

    K[i]:=max;

    end;

    end;

    writeln ('сумма = ', sum) ;

    writeln ('Новый массив') ;

    for i:=1 to 37 do begin

    write (K[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив K[1 ... 37] в интервале от 0 до 100. Найти сумму элементов массива, которые являются 2-х значными числами и кратные 3, и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
Массив заполнен случайным образом 20 числами в интервале от 0 до 100. 1) найти максимальный и минимальный элемент массива, а так же их сумму 2) найти среднее арифметическое элементов массива 3) из элементов массива сформировать два массива с четными
Ответы (1)