Задать вопрос
24 сентября, 06:28

С клавиатуры вводятся действительные числа x и y. Если x и y положительные, то каждое число удвоить; если оба значения принадлежит отрезку [-9; - 3], то оба значения увеличить в десять раз; в остальных случаях найти произведение

+3
Ответы (1)
  1. 24 сентября, 08:50
    0
    Var

    x, y:real;

    begin

    readln (x, y) ;

    if (x>0) and (y>0) then

    begin

    x * = 2; y * = 2;

    print (x, y) ;

    end else

    if (x>=-9) and (x=-9) and (y<=-3) then

    begin

    x * = 10; y * = 10;

    print (x, y) ;

    end else write (x*y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводятся действительные числа x и y. Если x и y положительные, то каждое число удвоить; если оба значения принадлежит отрезку ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)