Задать вопрос
24 сентября, 02:36

Написать программу, которая находит произведение элементов массива. Размерность массива 10 элементов. Ввод элементов осуществлять с клавиатуры.

+1
Ответы (1)
  1. 24 сентября, 04:10
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i:integer; p:real;

    begin

    for i:=1 to n do read (a[i]) ;

    p:=1;

    for i:=1 to n do p:=p*a[i];

    writeln ('p = ', p) ;

    end.

    Пример:

    4 6 2 3 8 1 4 7 9 1

    p = 290304
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая находит произведение элементов массива. Размерность массива 10 элементов. Ввод элементов осуществлять с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая находит минимальный элемент массива. Размерность массива 4 х4. Ввод элементов осуществляется с клавиатуры.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Организовать ввод чисел в массив E состоящий из 7 элементов ввод с клавиатуры сформировать новый массив К состоящий из элементов которые равны квадратам элементов массива Е вывести элементы массива Е найти и вывести номер минимального элемента
Ответы (1)