Задать вопрос
8 июля, 05:29

Вычислить и вывести на экран значение функции Y=Y (x) для всех x из диапазона (XL, XR) с шагом k (k< XR-XL). Для всех значений x, в которых функция Y (x) не существует вывести сообщение "Функция не существует". Числа XL, XR, k пользователь вводит с клавиатуры. Значение функции выводить с точностью до 2 цифр после десятичной точки

Функция: Y=|sinx|+cos|x|

+4
Ответы (1)
  1. 8 июля, 05:39
    0
    Var

    xl, xr, h, x:real;

    i:integer;

    begin

    Write ('Введите левую и правую границы изменения х, затем шаг: ') ;

    Read (xl, xr, h) ;

    for i:=1 to Trunc ((xr-xl) / h) + 1 do begin

    x:=xl + (i-1) * h;

    Writeln (x:0:4,' ', abs (sin (x)) + cos (abs (x)))

    end

    end.

    Пример

    Введите левую и правую границы изменения х, затем шаг: 1.2 3 0.18

    1.2000 1.2943968404439

    1.3800 1.17149436167019

    1.5600 1.01073783728823

    1.7400 0.817321730886476

    1.9200 0.597495822534427

    2.1000 0.358363262049017

    2.2800 0.107651047653376

    2.4600 - 0.146539653537401

    2.6400 - 0.395995275405633

    2.8200 - 0.632655254626053

    3.0000 - 0.848872488540578
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить и вывести на экран значение функции Y=Y (x) для всех x из диапазона (XL, XR) с шагом k (k< XR-XL). Для всех значений x, в которых ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
Пользователь клавиатуры вводит в минуту 60 знаков. Какое количество текстовой информации вводит этот пользователь за 5 минут в кодировке Unicode?
Ответы (1)
1. Прочитать с клавиатуры число n, затем прочитать n чисел и вывести на экран сумму тех из них, которые делятся на 3. 2. Прочитать с клавиатуры число n и вывести на экран сумму его четных цифр 3.
Ответы (1)