Задать вопрос
26 апреля, 19:50

Помогите с программой.

Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36). Выпадающее число генерируется случайным образом в программе. Если. пользователь угадал, то его ставка увеличиваетсяив 36 раз и возвращает в его банк. Если. не угадал, то не возвращает. Далее пользователю выдается сообщение о том, сколько денег у него осталось и задается вопрос, хочет он продолжать или нет. Игра продолжается до тех пор, пока пользователь не захочет завершить игру или у него не закончатся деньги.

+2
Ответы (1)
  1. 26 апреля, 20:58
    0
    Begin

    Writeln ('Введите имя игрока ') ;

    var name : = ReadString;

    Writeln ('Введите сумму ') ;

    var sum : = ReadInteger;

    while True do

    begin

    Writeln ('Введите ставку от ', 1, ' до ', sum) ;

    var stavka : = ReadInteger;

    if stavka > sum then

    writeln ('Ставка не может превышать имеющиеся наличные')

    else

    begin

    sum - = stavka;

    Writeln ('Введите число от 1 до 36') ;

    var number : = random (1, 36) ;

    var getnumber : = ReadInteger;

    if (getnumber 36) then

    Writeln ('Неверное число. Вы потеряли ставку!')

    else

    if number = getnumber then

    begin

    Writeln ('Вы угадали! Вы получаете 36 х ставку') ;

    sum + = (36 * stavka) ;

    end

    else

    Writeln ('Не угадали. Вы потеряли ставку!')

    end;

    writeln;

    Writeln ('Имя игрока ', name) ;

    Writeln ('Текущие деньги ', sum) ;

    writeln;

    if (sum < = 0) then

    begin

    Writeln (name, ', Вы Проиграли! Надеюсь, Вам повезет в следующий раз') ;

    break;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Программа спрашивает стороны прямоугольника, находим площадь и выводим на экран результат. Далее программа спрашивает любое число если число делиться на 5 выводит на экран сообщение число кратно 5 иначе выводит сообщение число не кратно 5 далее
Ответы (1)
1) собственное имя файла: а) задает пользователь б) задается программой автоматически 2) Расширение: а) задает пользователь б) задается программой автоматически
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Составьте программу, которая задает пользователю вопрос, требующий однозначного ответа; предлагает пользователю несколько подсказок и попыток.
Ответы (1)