Задать вопрос
29 июля, 03:09

Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z. Определите, какая из кошек первой доберется до мыши, если кошки передвигаются с одной скоростью. В случае если кошки одновременно добираются до мышки, то тогда кошки ссорятся из-за добычи, и мышь ускользает от них. Формат входных данных Единственная строка входного файла содержит три целых числа x, y, z (1 < = x, y, z < = 1

+3
Ответы (1)
  1. 29 июля, 04:22
    0
    Меня настораживают ограничения. Они что, все в одной точке? Тогда все ясно. Я взял ограничения - 2^16<=x, y, z<=2^16.

    var x, y, z:real;

    begin

    read (x, y, z) ;

    if abs (x-z) = abs (y-z) then writeln ('Мышь ускользает') ;

    if abs (x-z) >abs (y-z) then writeln ('Мышь ловит вторая кошка с координатой ', y) ;

    if abs (x-z)
    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль абс Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z.
Ответы (1)
Две кошки загнали мышь в трубу. первая кошка находится в точке с координатой x, вторая кошка находится в точке координатой у, мышь находится в координате z.
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
Вам дана строка S. Надо определить, сколько в ней цифр Формат входных данных Единственная строка входного файла содержит строку S, которая может состоять из букв английского алфавита и цифр.
Ответы (2)
Задача W. Сумма двух чисел Имя входного файла: sum. in Имя выходного файла: sum. out Ограничение по времени: 2 секунды Ограничение по памяти: 256 мегабайт Формат входного и выходного файла На первой строке входного файла находятся два целых числа a
Ответы (1)