Задать вопрос
25 января, 06:21

Паскаль абс

Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z. Определите, какая из кошек первой доберется до мыши, если кошки передвигаются с одной скоростью. В случае если кошки одновременно добираются до мышки, то тогда кошки ссорятся из-за добычи, и мышь ускользает от них. Формат входных данных Единственная строка входного файла содержит три целых числа x, y, z (1 < = x, y, z < = 1 000). Все числа различны. Формат выходных данных Если первая кошка доберется до мышки раньше второй выведите "1" (без кавычек). В случае если вторая кошка доберется до мыши раньше первой выведите "2" (без кавычек). В случае если мышка ускользает выведите "3" (без кавычек).

+2
Ответы (1)
  1. 25 января, 08:43
    0
    Var x, y, z:integer;

    begin

    readln (x, y, z) ;

    if abs (x-z)
    then writeln (1)

    else if abs (x-z) >abs (y-z)

    then writeln (2) else writeln (3) ;

    end.

    Пример: 2 8 4

    1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль абс Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Две кошки загнали мышь в трубу. Первая кошка находится в точке с координатой x, вторая кошка находится в точке с координатой y, мышь находится в координате z.
Ответы (1)
Две кошки загнали мышь в трубу. первая кошка находится в точке с координатой x, вторая кошка находится в точке координатой у, мышь находится в координате z.
Ответы (1)
Задача A Дана последовательность чисел А длины N. Требуется вывести в обратном порядке. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 1000000) - длину последовательности.
Ответы (1)
задается целое число N. нужно вывести количество четных делителей числа N. Формат входных данных Единственная строка входного файла содержит единственное целое число N (1
Ответы (1)
Задача D Нечет Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B. Формат входных данных Первая строка входного файла содержит два целых числа A и B (1 < = A, B < = 10^9). Формат выходных данных Выведите ответ к задаче.
Ответы (1)