Задать вопрос
18 августа, 15:08

Дано натуральное число. Определить является ли оно палиндромом. Написать процедуру получения нового числа. Паскаль

+4
Ответы (2)
  1. 18 августа, 17:24
    0
    Procedure inverse (var a: integer) ;

    var i, k: integer;

    begin

    k:=a; i:=0;

    while k>0 do

    begin

    i:=i + (k mod 10) ;

    k:=k div 10;

    if k>0 then i:=i*10;

    end;

    a:=i;

    end;

    / / основная программа

    var k, n: integer;

    begin

    write ('число: ') ; readln (n) ;

    k:=n;

    inverse (n) ;

    if k=n then writeln ('палиндром')

    else writeln ('не палиндром') ;

    end.

    число: 123456754

    не палиндром

    число: 456898654

    палиндром
  2. 18 августа, 18:26
    0
    Var n, m:integer;

    procedure inverse (a:integer; var b:integer) ;

    begin

    b:=0;

    while a>0 do

    begin

    b:=b*10+a mod 10;

    a:=a div 10;

    end;

    end;

    begin

    write ('n = ') ;

    readln (n) ;

    inverse (n, m) ;

    if n=m

    then writeln ('Число - палиндром')

    else writeln ('Число - не палиндром') ;

    end.

    Пример:

    n = 123321

    Число - палиндром
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число. Определить является ли оно палиндромом. Написать процедуру получения нового числа. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Слово называется палиндромом, если оно читается одинаково, как слева направо, так и справа налево. Требуется определить, какое минимальное количество букв надо добавить к входному слову справа, чтобы оно стало палиндромом.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Строка является палиндромом, если слева направо и справа налево она читается одинаково, например "кабак", "боб", "asdfggf' dsa". Составьте алгоритм и напишите программу, определяющую, является ли строка палиндромом.
Ответы (1)
Написать программу на языке Pascal Палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево.
Ответы (1)