Задать вопрос
24 февраля, 06:30

Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них отрицательных, которые кратны 3.

+1
Ответы (1)
  1. 24 февраля, 10:03
    0
    Var a, i, k:integer;

    begin

    k:=0;

    writeln ('Введите 15 целых чисел:') ;

    for i:=1 to 15 do

    begin

    readln (a) ;

    if (a<0) and (a mod 3 = 0) then k:=k+1;

    end;

    writeln ('k = ', k) ;

    end.

    Пример:

    Введите 15 целых чисел:

    75

    -65

    15

    -68

    28

    -42

    80

    -76

    51

    -32

    18

    -16

    -45

    70

    -65

    k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая обеспечит ввод 15 чисел и определит сколько из них отрицательных, которые кратны 3. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)
Написать программу, начинающуюся с команды Ввод, заканчивающуюся командой Вывод. Программе на ввод дается h1, m1, s1 и h2, m2, s2 Это часы минуты и секунды начала отсчета и конца отсчета времени.
Ответы (2)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и подсчитать количество введённых положительных и отрицательных чисел.
Ответы (1)
Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Признаком конца последовательности является ввод 0.
Ответы (1)