Задать вопрос
31 марта, 14:14

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел

вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход

целые числа, количество введённых чисел неизвестно, последовательность чисел

заканчивается числом 0 (0 - признак окончания ввода, не входит

в последовательность).

Количество чисел не превышает 1000. Введённые числа по

модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,

которые кратны 6 или 11.

+1
Ответы (1)
  1. 31 марта, 17:34
    0
    Uses crt;

    var a, sum:integer;

    begin

    sum:=0;

    repeat

    read (a) ;

    if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;

    until a=0;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
17. Напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3.
Ответы (1)
напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0.
Ответы (1)