Задать вопрос
20 февраля, 20:46

Написать программу, начинающуюся с команды Ввод, заканчивающуюся командой Вывод. Программе на ввод дается h1, m1, s1 и h2, m2, s2 Это часы минуты и секунды начала отсчета и конца отсчета времени. Необходимо вывести количество секунд между этими двумя значениями. Ввод h1, m1, s1 Ввод h2, m2, s2 ... расчет Вывод M Все действия необходимо сопроводить комментариями, с указанием, что делается, что вычисляется.

+5
Ответы (2)
  1. 20 февраля, 23:03
    0
    Var

    h1, h2, m1, m2, s1, s2: integer;

    begin

    read (h1, m1, s1) ;

    read (h2, m2, s2) ;

    writeln ((h2 - h1) * 3600 + (m2 - m1) * 60 + s2 - s1) ;

    end.
  2. 20 февраля, 23:57
    0
    Var

    h1, h2, m1, m2, s1, s2: integer;

    begin

    read (h1, m1, s1) ;

    read (h2, m2, s2) ;

    writeln ((h2 - h1) * 3600 + (m2 - m1) * 60 + s2 - s1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, начинающуюся с команды Ввод, заканчивающуюся командой Вывод. Программе на ввод дается h1, m1, s1 и h2, m2, s2 Это часы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. напишите программу которая вводит значения 3 переменных a и b с приглашениями к ввожу каждой переменной и выводит их разность. Приглашение и ввод каждого значения произвести в отдельных строках. Ввод сопроводить пояснениями. 2.
Ответы (1)
Как это решать? И что тут вообще надо сделать? A+B Ограничение времени 1 секунда Ограничение памяти 64Mb Ввод стандартный ввод или input. txt Вывод стандартный вывод или output. txt Даны 2 числа a и b. Найти сумму этих чисел.
Ответы (1)
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
1. На вход программе даётся число N и N чисел (все натуральные 24; 5 13 4 16 100 8 = > 4 2.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)