Задать вопрос
17 октября, 08:47

Y=X*COS (X) + SIN (X)

Написать программу 2 способами: цикл с параметром и с предусловием

Pascal ABC

+1
Ответы (1)
  1. 17 октября, 12:22
    0
    1)

    const x0=1.0; xk=2.0; h=0.1;

    var x, y:real; i:integer;

    begin

    x:=x0-h;

    for i:=1 to round ((xk-x0) / h) + 1 do

    begin

    x:=x+h;

    y:=x*cos (x) + sin (x) ;

    writeln (x:3:1, y:7:3) ;

    end;

    end.

    2)

    const x0=1.0; xk=2.0; h=0.1;

    var x, y:real;

    begin

    x:=x0-h;

    while x
    begin

    x:=x+h;

    y:=x*cos (x) + sin (x) ;

    writeln (x:3:1, y:7:3) ;

    end;

    end.

    Результат:

    1.0 1.382

    1.1 1.390

    1.2 1.367

    1.3 1.311

    1.4 1.223

    1.5 1.104

    1.6 0.953

    1.7 0.773

    1.8 0.565

    1.9 0.332

    2.0 0.077
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Y=X*COS (X) + SIN (X) Написать программу 2 способами: цикл с параметром и с предусловием Pascal ABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Напишите программы в Паскале: 1) цикл с предусловием. Написать программу, вычисления у=х2 при х=2, 4, 6, 8, 10; 2) цикл с постусловием.
Ответы (1)